DIFFERENCE BETWEEN COMPUTER SOFTWARE AND HARDWARE
 

While computer jargon can be hard to get to grips with, two terms that pop up extremely often in any computer discussion are the words "software" and "hardware". 

 

But what is the difference between computer software and hardware? 

 

These two terms refer to the most fundamental parts of computer systems. Both of them are vital for any computer to operate, and they are also dependent on one another, as you can see in this article about how computers work. 

 

 

Definition of Computer Hardware and Software
 When we talk about computer hardware, we mean the actual components of your computer. Such things as the computer’s motherboard, its CPU, the video card, the keyboard and mouse, these are all "hardware". 

 

The difference between computer software and hardware is that software refers to the coding and various programs that you have on your computer. These include your operating system (Windows etc), media players, Photoshop etc.

  

Purpose
Computer hardware is usually multi-purpose in that it is able to perform lots of different tasks. For instance, your computer monitor doesn't just display images on screen; it also shows videos, widgets and text. One difference between computer software and hardware is that software is normally only designed to perform one task. 

 

Your media player for example, is only for accessing media like movies and songs. It cannot edit photos or browse the web. The only real exception to this is the operating system itself, which is a user-friendly interface designed to let you access all the other bits of software and files stored on your PC. 

 

 

System Requirements
 Computer software can only function on a computer if that computer meets the system requirements needed to run it properly. Such requirements include hard drive requirements, a minimum processor speed, RAM requirements and a supported operating system. 

 

Occasionally a piece of software will have additional requirements, and these will normally be printed on the box when you purchase it, or else it will be displayed on the website you have downloaded it from. 

 

 

Bit Rate 64 Bit vs 32 Bit
The transition in computers from operating systems of 32-bits to operating systems of 64-bits has become a recent issue with hardware and software. The difference between the two kinds of operating system are that 64-bit systems can access more RAM and are able to process much bigger data chunks than the old 32-bit systems. 

 

In order to run software that is 64-bit, it is necessary to have a 64-bit CPU along with a motherboard that is compatible with the software. Because there are many computers that don'’t have the hardware necessary to run the 64-bit versions of software, many manufacturers release both 64-bit and 32-bit versions of their programs. 

 Development
Both computer software and computer hardware are being constantly developed, with superior components and programs being released all the time. The development of hardware is usually focused on creating faster and more compact components through the use of new technology. 

Meanwhile, developers of software are constantly striving to keep pace with these new advancements in hardware by building smoother running, better looking and more comprehensive programs. The result of this is that computer users are constantly being required to update their hardware to be able to run the latest pieces of software. 

What is Computer Hardware?
There are a huge number of computer users out there who surprisingly enough, don’t know the answer to this question! So what is computer hardware exactly?

You need to think of your PC as a system, one that consists of various components. Some of them, like the version of windows you use and any other programs on your PC, are called software. Meanwhile, in answer to the question what is computer hardware, this is the stuff that you can actually see and feel, the bits that would break if you were to drop them, are called hardware.

 Not all of us use exactly the same bits of hardware. However, it'’s a pretty safe bet that most of us have a basic set up of the following hardware components.

System Unit
This is the actual computer - All the other bits are known as peripheral devices. When discussing what is computer hardware, this is the most important example we can give. 

 

The system unit, in the case of a desk top computer, is the big chunky thing that usually has a floppy drive and a DVD or CD drive. Inside the system unit there's actually another disc drive, which is called the hard drive, and this is where everything "in your computer" is stored.

 

 

RAM - Random Access Memory
Almost as common a question as "what is computer hardware?" is "What is RAM?" Abbreviated from "Random Access Memory", this is the part of the computer that stores whatever it is (files, programs and so on) that you are currently working on. 

 

When you open a file up, the computer basically "moves" it into the RAM memory. The reason the computer does this is that RAM works very fast, much faster than your hard drive, and so it means a lot less waiting around for you.

So you're probably thinking, why not just store everything on the RAM? The reason we don't is because RAM is very unreliable. RAM cannot store information when the power is turned off, either by accident or intentionally, and so we have to use the hard drive for long term storage.

Computer Hard Drive
As we've just mentioned above, this is where everything stored on your computer goes. We don't actually see the hard drive because it is housed inside the system unit and needs to stay there. 

Quite the opposite of the highly volatile RAM, hard drives are able to store data permanently, with or without power. Most hard drives nowadays have huge memories, into the billions of bytes, which means that we are able to use our computers for years without filling them up.

Computer Mouse
What of the simplest examples of "what is computer hardware?" is this extremely handy tool. The mouse is a quite essential piece of hardware for any computer user, as it allows us to navigate through our computers quickly and easily. While it is actually possible to do everything on your computer without a mouse, this would be much more difficult and time consuming!

Computer Keyboard
Another indispensable part of your computer hardware, the keyboard is absolutely vital for interacting with your PC. You need the keyboard, quite simply, to type. The chances are that you will need to type at least one or two words almost every time you log onto your computer, whether it's just a password, a URL, or even just the "Enter" key. Find more information on the computer keyboard, the layout and the different types of keyboards.

So what is Computer RAM? 

Computer RAM (random access memory) is a volatile data storage device. It is used by the computer to temporarily store data. When the computer is turned off all the data stored on the computer memory is lost. 

 

The words 'random access memory' refers to the fact that any byte of data can be accessed directly by the computer instead of it searching in order till it finds it (such as in a cassette tape). 

 

RAM operates at very fast speeds and is crucial to the health of a computer. RAM was measured in ns (nanoseconds) which equals one billionth of a second but with the introduction of SDRAM is now measured in MHz (megahertz). 

 

Computer memory (RAM) is placed into the memory slots of a motherboard meaning that it is easy to upgrade or swap if the memory breaks. Computer memory is needed for everything so it is important to have enough. 

Types of RAM

There are two basic types of RAM: Dynamic RAM (DRAM) and Static RAM (SRAM). Dynamic RAM is the more common and needs to refreshed thousands of times per second. Static RAM does not need to be refreshed making a lot faster but also much more expensive. 

 

To find out more information about the different types of RAM click on the type of RAM below that you want to learn about. 

What does RAM do?

Operating systems, application programs such as Microsoft word, Firefox or a game program are kept in the RAM so as to be quickly accessed by the CPU. Computer RAM is much faster then other storage devices but it will lose all its information when the computer is switched off. When you turn your computer on again then the information is loaded from the hard drive or CD drive back to the RAM and the process begins again. 

 

The more programs you have opened up at the same time the lesser amount of computer memory can be distributed. If you have a small amount of RAM this could slow down your computer considerably. However, the more RAM you have the faster programs can run and the more programs you can have running. If your RAM fills up, then the processor will need to send the information to the hard disk slowing down your computer.

RAM Specifications

RAM is measured by its speed (MHz) and by its size (megabytes or gigabytes). For example you could have DDR RAM (name) 400mhz (speed of the RAM) 256mb (RAM size). The most common RAM sizes are, 16mb, 32mb,64mb, 128mb, 512mb, 1Gb and 2Gb. DDR RAM will only go into a motherboard supporting DDR. This is the same for SDRAM and DDR2RAM. 

What is a ROM in a computer?

ROM stands for Read Only Memory. It is permanent memory in a computer that cannot be changed. It is need for the computer to work. Most memory is wiped clean when you turn off your computer. If it lost all memory it would not be able to start up again. So it needs some instructions stored in memory that is there when the computer starts. It then uses this to give further instructions to the computer and help it boot up. If you watch your screen when a computer is booting, you will see lots of things happening. You will normally see a mention of ROM at some stage of the process. 

What does a ROM do in a computer?


Read-only memory (usually known by its acronym, ROM) is a class of storage media used in computers and other electronic devices. Because data stored in ROM cannot be modified (at least not very quickly or easily), it is mainly used to distribute firmware (software that is very closely tied to specific hardware, and unlikely to require frequent updates).

Role of rom in computer?

First of All ROM stands for READ ONLY MEMORY the role of ROM in computer is to store all the Information about any computer hardware such as the processor speed, CD-ROM/DVD-ROM drives etc. It is a permenant memory which contains also BIOS (basic input output system) configuration and settings.

Introduction

The Windows XP Operating System is a graphical user interface (GUI) developed by the Microsoft Corporation. The purpose of this document is to assist the user in learning the basic fundamentals of the Windows XP Operating System. The Introduction to Windows XP workshop is recommended for people unfamiliar with computers and will serve as a foundation for the other Windows related workshops.

Basic Terminology

• Monitor: The television-like screen that displays the visual representation of the computer’s contents.

• Floppy Disk: Storage device used for storing small programs or data. Most diskettes are 3.5” in size and can store 1.4 Megabytes (MB) of information. A new kind of diskette, called a Zip Disk, can hold as much as 250 MB or more.

• Hard Disk: Storage device found in the computer which is used for storing instructions and data. Hard disks are capable of storing gigabytes (GB) of data (thousands of Megabytes).

• CD-ROM: Compact Disk Read Only Memory storage media. CD-ROMs have a similar appearance to audio CDs. Computer programs are often stored on these discs because of their large storage capacity.

• CD-R/RW: A compact disk, similar to a CD-ROM, except it can have information recorded on it. Some types are capable of being recorded multiple times.

• RAM: Random Access Memory. RAM is found inside the computer and is used to temporarily store instructions and data for processing.

• Mouse: A handheld device which controls cursor movements on the screen. A button on the mouse can be used to select programs/files by clicking once on the program/file icon. It can also be used to launch programs/files by rapidly clicking twice on the icons (double clicking).

• Left-Click: Pressing the left button of the mouse once. (Used for selecting icons and opening programs.)

• Right-Click: Pressing the right button of the mouse once. (Used for opening contextual menus.)

• Single-Click: Clicking once (with the left mouse button) on the icon to select the icon.

• Double-Click: Clicking twice (with the left mouse button) on the icon to activate the icon. Activating the icon will run the program or open the file that is associated with the icon.

• Drag/Drag-and-Drop: This is used to move files around on the computer. It may also be used to copy files from hard drive to floppy drive and vice-versa. To drag a file, left-click and hold down the button. Move the icon to the new location and let go of the mouse button.

Network Login

Northeastern Illinois University uses a Novell Network for file sharing. To log on to the NEIU Network, press the OK button at the Novell Login screen. You now have access to the various programs that are network accessible.

Windows

Desktop

The computer screen that is displayed is called the Desktop. As you move the mouse around with your hand, you see the mouse pointer move accordingly on the computer desktop. The icons on the desktop correspond to commonly used programs found in the computer. These icons are actually shortcuts to the programs themselves and double-clicking the icons will launch the programs automatically.
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You can also use the right mouse button to open up different commands. Right-click on an empty area of the desktop and arrange the icons by name.

My Computer

The My Computer icon will show a listing of the computer’s disk drives, network drives, and system files/folders. Local files or folders are found on the computer’s drives whereas remote files or folders are found on the network drives. Double-clicking on the drive letter will open the contents of that drive.

You can also right-click on the icons to do advanced functions.

Title Bar

The Title Bar shows the name of which window you are viewing.

Menu Bar

Select View from the Menu Bar and click Toolbars, and then click Customize

(From now on, selecting options will be shown as View -> Toolbars -> Customize)

You are able to customize the toolbars and menus that are available for quick access.
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By selecting View -> Tiles, you are able to customize the way files, folders, and or programs are displayed to give you detailed information or a preview of what the file contains.

My Documents

The My Documents folder is the default folder where most of the Windows XP programs will save your files.

Taskbar

All open windows will be accessible via the Taskbar. You can select them by clicking on the button that they formed when they were first opened.

Time and date are found on the right-hand side of the Taskbar and can be changed by double clicking on the numbers that display the time.

7

Start Menu

The Start Menu contains shortcuts to the most commonly used programs that are found on your computer.

Clicking Start -> Programs -> Accessories -> Calculator will launch the calculator program

If you know the name of the program you want to open, go to Start -> Run and type in the program’s name. For example, if you want to open the calculator program, go to Start -> Run and type in the name calc. Click the OK button.
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Explorer

Go to Start -> Run and type Explorer. Click the OK button. (You can also right-click on the Start Menu Button and select Explore All Users.) This will allow you to create and maintain shortcuts in the Start Menu and other folders on the computer. (University machines will not allow you to create shortcuts in the Start Menu.)

Minimize/Maximize/Restore/Close

Every window in the XP operating system will have a series of buttons on the top right corner of the Title Bar. Close Maximize Minimize Restore Window

File Management (Exercise)

Objective/Goal: Basic file creation and maintenance by performing various tasks on the computer.

New File

Go to Start -> Run and type Explorer. Click the OK button. In the Explorer Window, select File -> New -> Microsoft Word Document
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Name it temp.doc and click the OK button.

Open File

Open the file you just created by double-clicking on it. You can also open the file from the Menu Bar by selecting File -> Open.

With the new file open, enter your name in the open area of the Microsoft Word document.

Save (As)

Select File -> Save As

Enter your name as the File name:.

Click on the down arrow where it says to Save as type:.

Select to save the file as Rich Text Format (*rtf).

Click Save and close the file.

NOTE: By saving the text file as the Rich Text Format, you are able to open this file on any type of computer and work on it even if they do not have the Microsoft Word software installed on the machine. Furthermore, saving it this way allowed you to make a backup copy of the file that was created. Making backup copies of files is one of the best practices a computer user can do. Remember to make regular backup copies of your important files and keep the backups in a safe place.
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Copy

Another way to make a backup copy of your files would be to:

• Locate the file you want to copy in My Computer or Windows Explorer.

• Select the file you want to copy by clicking once on the file.

• Select Edit from the Tool Bar and click on Copy.

• Select Edit from the Tool Bar and click Paste.

• You now have a copy of the file you selected.

You can also right-click on the file you want to copy and left-click on the Copy command. Now move to an empty area of the window you are currently in and right-click that spot. Select Paste.

Unzip

NOTE: A zipped file is a compressed file that was created by a program to save disk space. Windows XP has an automatic unzipping utility that will allow you to open zipped files on disk. Place the floppy disk that was loaned to you at the beginning of the workshop in the floppy disk drive. In the Explorer Window, select My Computer and click on 3½ Floppy A: drive. Double click on the file text_zip.zip.

You can drag-n-drop this file to the My Documents folder. Move the mouse pointer over the file, left-click once on the file and while holding your finger down, drag the mouse over so the pointer will be on top of the My Documents folder and let go of the file by taking your finger off of the mouse.

Print

Open the new file and select Print from the File Menu.

Close the file.

NOTE: Each computer lab on campus will have a different Print Dialog box. Press the OK button and a lab assistant will be available to help you with your print out. 11

Delete

From the Menu Bar, select File -> Delete

Click the Yes button.

Recycle Bin

Locate the Recycle Bin icon on the Desktop.

Find the file you just deleted and select it by clicking on it once. From the Menu Bar, Select File -> Restore
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The file will have been restored to the directory it was deleted from. If you do not remember which directory the file was in when it was deleted, you can search for it by using the Search Feature.

NOTE: University machines will not restore a file after the machine has been restarted.

Search

To search for the file that was just restored, Click the Start Menu button, and select Search ->For File or Folders …

There are various ways to search for files and folders. You are able to search by file name or words found in the file you are looking for. You can search specific areas of your hard drive or for files that were created or modified on a certain date. Test some different ways of searching to see which one works best for you.
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Double-click on the icon to open it

Also, the most recent files that were opened will be found in Start Menu -> Documents

Help

The Help and Support Center can be a vital source of information. Click the Start Menu and select Help and Support.
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You can type in a word or phrase to search for or select topics that might be useful. Try typing the word Restore.

Antivirus

Locate the Norton Anti-Virus icon on the right-hand side of the Task Bar and double-click it.

Insert the disk we loaned you into the floppy drive. Select the option of Scan -> Scan a Floppy Disk. There should be a checkmark next to the Floppy Disk.

Press the button.
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The scan will complete and tell you whether or not there is a virus on the disk. If a virus is found, follow the on screen instructions to disinfect. You may also contact one of our student lab assistants for help. When scanning is complete, close the open window and Exit the program.

< END OF EXERCISE >

Log Off/Shutdown/Restart

To restart your computer or turn your computer off, click the Start Menu Button and select Shut Down …

You will now have the option to log off the computer, turn your computer off or restart the computer. Select what you want to do and click the OK button.

Alternatively, pressing CTRL-ALT-DEL (hold down the Ctrl key, the Alt key, and the Delete key on the keyboard) simultaneously will bring up these options also.
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Pressing the Logout button will prompt you if you want to end your Windows session. This will close down all programs you had open and will make the computer available for a new user.

Pressing the Shutdown button will ask if you want to turn off or restart the system. If you restart the system, the computer will refresh all settings and computer memory will be restored for a new user.

